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Abstract. Objective tests in assessments have been used in most undergraduate courses. Many issues arise in the development of 
multiple sets of tests such as difficulty, multiple choice type and multiple choice form. Graphical tests are a matter of concern for 
enhancing virtual interoperability and enhancing teaching quality. This paper introduces how to use Macromedia Flash software
in creating multiple-choice graphic questions in a number of different forms. On that basis, we have used to build a graphic 
problem set for Computer Architecture.
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Tóm tắt.Trắc nghiệm khách quan trong kiểm tra đánh giá đã và đang được sử dụng trong hầu hết các môn học ở Đại học. Nhiều 
vấn đề đặt ra trong việc xây dựng các bộ đề trắc nghiệm như độ khó, dạng trắc nghiệm và hình thức trắc nghiệm. Trắc nghiệm 
dạng đồ họa đang là một vấn đề được quan tâm nhằm nâng cao khả năng tương tác ảo và nâng cao chất lượng dạy học. Bài báo 
này giới thiệu cách thức sử dụng phần mềm Macromedia Flash trong việc tạo các câu hỏi trắc nghiệm đồ họa với một số hình 
thức khác nhau. Trên cơ sở đó, chúng tôi đã vận dụng  để xây dựng bộ đề trắc nghiệm đồ họa cho học phần Kiến trúc máy tính.

Từ khóa: Trắc nghiệm đồ họa; Kiến trúc máy tính; Trắc nghiệm kiến trúc máy tính;Trắc nghiệm trực tuyến;Phần mềm Macromedia 
flash

1. SET THE PROBLEM

Computer architecture is an important discipline in the 
specialized training of information technology, its main 
research subject being computer and computer functions. 
This subject is both abstract and concrete, both theoretical 
and practical, and the subject is highly valued in practical 
application. 

Specificity and abstractly
* Specificity: Course content includes the knowledge of 

computers, computer components. Specifically, the 
structure of the equipment, operating procedures, skills, 
techniques in assembly and operation. 

* Abstraction: the content also has the knowledge of 
algorithms, algorithms inside the computer. This is highly 
abstract knowledge. To acquire this knowledge requires not 
only direct interaction with the computer but also requires 
that the teacher needs to have a simulation, visual model is 
highly interactive for students, use Right on the computer to 
describe the algorithm taking place inside it. 

Theoretical and practical 
*Theoretical: Structures, algorithms in the programming 

of computing requires logic and optimization. 
* Practicality: The subject knowledge is applied in real 

life such as design, production, assembly and use of 
computers. 

With the above characteristics required to test the subject 
assessment of this subject in online training are:

- Firstly: Check the knowledge  components, basic 
technical parameters of components, processes, principles 

of operation:
This section may use multiple choice questions. We have 

built a series of 400 questions to test online reviews [5].
- The second is: Test knowledge such as: device 

identification, device assembly, distinguishing 
components on a system:

To test this part effectively, it is best to do it on a real 
device in the lab, but this is difficult because it is an online 
learning environment (virtual learning environment). There 
is no practical room with visual equipment as in traditional 
training. And this section can not use the text-based 
questionnaire for effective assessment as it is a visual 
assessment test.

In order to be able to effectively assess and evaluate this 
content, we propose a solution that uses a graphical set of 
questions in the online assessment of Computer 
Architecture.

2. RESEARCH CONTENT

2.1 Objective testing

According to [1,2,3,4], the Test is an activity to measure 
certain subjectivity for specific purposes. Test is a form 
where a test consists of a series of questions, each with a 
question, with the necessary information so that the learner 
can respond only briefly to each question.

Tests are a method of evaluating student learning 
outcomes in which the effects of subjective factors are 
minimized to an optimal level. The highlight of this method 
is the number of questions in each test, the larger the 
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number of questions, the greater the accuracy of the 
assessment. Multiple-choice questions will include a 
concept, content included in the program, with suggestions 
for participants to answer. From the suggested answer we 
will have many different test questions.

2.2 Compulsory graphic study of computer architecture

According to [1] the test is divided into the following 
five main types of questions: Multiple choice tests, "true-
false" tests, pairwise tests, gap tests, . In order to construct a 
set of graphic tests (using images for review) appropriate 
for the computer architecture course, we would like to 
export the following three types of multiple choice 
questions:

Type 1: Double Test
- Questions are organized as two groups of objects 

(images), students need to drag and drop objects belonging 
to the first group to a second group object for pairing.

- This type of exercise is used to test the student's ability 
to assemble computer components. To accomplish this task, 
students must have a general knowledge of computer 
components such as basic technical parameters, structure 
characteristics, device identification, Analyzer to select the 
device.

Second form: Object-selection tests
- Questions are organized in the form of a group (4 or 

more objects), students will select one or more subjects as 
required by the question.

- This type of exercise is used to test the application of 
the learner's knowledge into practice because in order to do 
this exercise, the learner needs to understand the basic 
parameters of the device, the device identification and how 
to use it. Those devices are in fact.

Third form: Multiple choice test on an object
- Questions are organized in the form of a picture and the 

person who needs to select a position on the photo is the 
right answer.

- This type of exercise is used to test the ability to 
recognize and distinguish details in a master block. (For 
example, identify the socket on the motherboard, which is 
the CPU cache memory. ) Of practitioners in practice. To 
do this exercise requires the student to be familiar with the 
composition of the computer components, how to read the 
specifications on the actual device.

2.3 Construct a graphic test

2.3.1Macromedia Flash Test Builder

Now,there are  many tools used to create E-learning 
quizzes such as Hot Potatoes, Lacture Maker, Adobe 
Presenter, Moodle, etc. The weakness of these software is 
the ability to create multiple-choice questions. Graphic 
format. To meet the requirements set out in the construction 
of the computer architecture test suite we selected the 
Macromedia Flash tool. This is a 2D graphic design tool, 
with its powerful 2D graphics capabilities, it is also used in 
E-learning to build electronic lecture, simulation, and 
problem solving. One application we mentioned in this 
article is to use Macromedia Flash to create a set of 
graphical tests.

Macromedia Flash supports six types of multiple 
choice questions:

- Type1: True - False: Each question usually has two 
options and in which a selection is determined to be TRUE, 
an option is defined as SAI.

- Type 2: Multiple Choice: Each question often has many 
options and some of which are determined to be the correct 
answer.

-Type  3: Fill in the Blank: Each question has a box for 
the participant to enter the value of the answer.

- Type 4: Drag and Drop: Each question is usually 
divided into two parts. The player needs to drop and drop 
the objects to the appropriate positions.

- Type 5: Hot Spot: Each question is usually represented 
by a photo and the person to whom the photo is to be taken 
is chosen.

- Type 6. Hot Object: Each question usually has many 
objects and people to choose by clicking on one of those 
objects.

Forms 1, 2, 3 have been used by many authors to develop 
a text format. In this article we study and use: form 4, form 
5, form 6 to build a specific image test as follows:

- Type 4 is used to build the double-vision image 
questionnaire.

- Type 5 is used to build object-oriented image choice 
questions.

- Type 6 is used to construct multiple choice image tests 
on an object.

2.3.2Build a graphical test suite with Macromedia Flash

A. Structure a set of multiple-choice questions

A sample set based on the available test sample that the 
software supports includes the following components:

- Introduction page (Welcome page)
- Question page
- Result page
- The buttons to move between the questions
- Program code

B. Create a set of multiple-choice questions

Step 1. Initialize the theme from the template

- Execute File -> New -> Template
- In the Category column select Quiz. In the Template 

column, select one of the three templates provided.

Step 2. Set basic parameters

- Click on Quiz Options (on the left of the presentation 
window - Stage)

- SelectWindow -> Development Panels -> Component 
Inspector

Parameters include:

+ Randomize: If selected, the questions will be displayed 
in random order. So, between the different runs, there are 
almost as many different checks.

+ Question to Ask: Enter the number of questions to use 
for each test. If the value is 0, all questions in the thread 
will be used. Typically, this value is less than the number of 
questions

+ Show Result Page: If selected, the results page will 
appear after the test is complete, informing you how many 
sentences you have completed.

+ Other options to set when there is a full online test 
system with full server.

Each question in the series is called an Interaction. When 
using the Quiz Template, questions are placed sequentially 
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into keyframes (keyframes) between the first keyframe and 
the last keyframe. The first keyframe is the Welcome page, 
which changes the interface as you like. The final keyframe 
is the result page.

Keyframes are displayed on the Interactions Layer. To 
change a question or to write a question, go to Keyframes 
located between the first Keyframe and the last Keyframe. 
These are important keyframes to master.

C. Add and remove a question

* Add a question to the thread
Step 1. On the first layer of the Timeline, select Frame in 

front of where you want to insert the question. Hold Shift, 
select the other frames the same position on the remaining 
layers.

Step 2. Right-click on the frame, select Insert Frames
Step 3. On the Interactions Layer, select the Inserted 

Frame, select Insert -> Timeline -> Blank Keyframe
Step 4. Next do one of the following:
Option 1: Copy & Paste: Select a reusable keyframe that 

has the same reusable question, right-click on the timeline 
and select Copy Frames. Then go back to the inserted white 
keyframe, right click on the keyframe, select Paste Frames.

Method 2: Using the Library Tool: Enabling the Library 
Window by Window -> Other Panels -> Common Libraries 
-> Learning Interactions. Then drag the question type from 
this window into the Stage.
* Remove a question from the thread

Step 1. On the Interactions Layer, select Keyframe 
containing the question to be deleted.

Step 2. Select Edit -> Timeline -> Remove Frames

D. Configuration for the question:

Step 1. Select the question (choose the keyframe that 
contains the question).

Step 2. Break the group of question idioms: Execute the 
command Modify -> Break Apart (this command is only 
used once). To check whether the question has been broken, 
try selecting and checking an object such as text box, radio, 
checkbox on the Stage. If it can be selected separately, the 
order has been executed successfully.

Step 3. Deselect all objects on the Stage (type Control + 
Shift + A).

Step 4. Click on Learning Interaction (usually under 
Quiz Options). The word Learning Interaction will be 
replaced by the name of the question form. In the example 
below, you will click on Multiple Choice Interaction

Step 5. Select Window -> Development Panels -> 
Component Inspector to resize the window accordingly to 
read the text, fill in the values for each question type.

E. Build questions

- Double format, use Drag and drop

Figure 1. Multilingual Image quiz maker tool

- Select object type, use Hot Objects

Figure 2. Image select questionnaire for object selection

- Form position selection on an object, use Hot Spot

Figure 3. The tool for creating image-based multiple choice 
questionnaire on object

F. Test
During the thread creation process, you can run tests to 

check for errors using the command:
Control -> Test Movie

G. Packaged threads

The created test can be packaged in two forms:
Type 1: The type of flash file (.swf), which can be 

uploaded to the learning site for online testing.
Type 2. Program (.exe) file type, which runs 

independently as a Windows application, is used to test 
directly on the computer.

To package the theme, perform the following steps:
Step 1. Go to File -> Publish Settings
Step 2. In the Formats tab, select Flash (.swf) or 

Windows Projector (.exe) for the purpose. In the File 
column, enter the corresponding filename. Switch to Flash 
or HTML Tabs (this section is for SCORM standard 
tracking: Flash with SCORM 1.2 tracking, this standard 
uploads a learning management system) to further declare 
parameters for posting to the Web.

Step 3. Click the Publish button to package the title.

2.3.3 Computer graphic design

After a period of research, we have successfully built a 
50-question computer-aided computer vision test, using the 
three types of multiple choice tests described above. This 
topic has been used to check the evaluation in online 
teaching computer architecture module for class 1d15 -
Faculty of Information Technology - Viet Tri University of 
Industry at www.khanhmckm.com. Specific types of 
questions were used to construct the series:

Example 1: Double vision test

For 4 CPUs and 4 sockets, ask the students to assemble 
the CPU corresponding to the sockets on the mainboard
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Figure 4. Double question
Students use the mouse, using drag and drop to assemble. 

During the assembly process, if the student wants to re-use, 
use the Reset button. When the student has finished 
selecting the Check Answer button to submit the post, the 
live system will report the result of the question is true or 
false.

Listing 2. Multiple choice questions

For 6 CPU, ask the students to choose which CPU has 3 
or more cores

Figure 5. Question form choice

Students select the CPU that satisfies the requirement, 
select the Check Answer button to submit the post, the 
system reports the results of the students.

Listing 3. Multiple choice questionnaire on object

For a picture of a motherboard, ask the student to 
indicate on the board where the socket is.

Figure 6. Multiple Choice Questionnaire
Students select the main sockets on the drawing, select 

the Check Answer button to submit the post. The system 
reports results to students.

After the student completes all questions the system will 
give the assessment results including:

+ Number of correct answers

+ Number of wrong answers
+ Total points

Figure7. Student performance results

2.4. Evaluate the results of the implementation of the 
graphic tests

Due to the framework of the article, we do not present 
empirical results but qualitative assessments.

For trainees: The use of images for evaluation has 
attracted participants to actively participate and evaluate the 
ability to apply in practice, creative thinking of students. 
Especially limiting the disadvantages of online assessment 
for technology courses (due to the fact that it can not be 
tested on real devices).

For teachers: Through a set of image tests, the trainees 
assessed some criteria of technology courses that difficult 
text responses to online teaching. Identify equipment, read 
specifications, pair equipment as well as distinguish 
components in actual systems.

3. CONCLUSION

Along with the development of Information Technology, 
graphic tests are a major issue that many educators are 
interested in, especially in the online teaching of technology 
subjects. In this paper, the author introduces the use of 
Macromedia Flash software to give a graphical test and the 
use of this tool successfully builds a graphical simulator of 
computer architecture. The results can also be used as 
reference material for the development of visual tests in 
other subjects.
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